strip the kernel version suffix from target directories, except for brcm-2.4 (the...
[openwrt-10.03/.git] / target / linux / adm5120 / patches-2.6.22 / 100-mtd_myloder_partition_parser.patch
diff --git a/target/linux/adm5120/patches-2.6.22/100-mtd_myloder_partition_parser.patch b/target/linux/adm5120/patches-2.6.22/100-mtd_myloder_partition_parser.patch
new file mode 100644 (file)
index 0000000..574b2d2
--- /dev/null
@@ -0,0 +1,39 @@
+Index: linux-2.6.22.1/drivers/mtd/Kconfig
+===================================================================
+--- linux-2.6.22.1.orig/drivers/mtd/Kconfig
++++ linux-2.6.22.1/drivers/mtd/Kconfig
+@@ -160,6 +160,22 @@ config MTD_AFS_PARTS
+         for your particular device. It won't happen automatically. The
+         'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
++config MTD_MYLOADER_PARTS
++      tristate "MyLoader partition parsing"
++      depends on MIPS_ADM5120 && MTD_PARTITIONS
++      ---help---
++        MyLoader is a bootloader which allows the user to define partitions
++        in flash devices, by putting a table in the second erase block
++        on the device, similar to a partition table. This table gives the 
++        offsets and lengths of the user defined partitions.
++
++        If you need code which can detect and parse these tables, and
++        register MTD 'partitions' corresponding to each image detected,
++        enable this option.
++
++        You will still need the parsing functions to be called by the driver
++        for your particular device. It won't happen automatically.
++
+ comment "User Modules And Translation Layers"
+ config MTD_CHAR
+Index: linux-2.6.22.1/drivers/mtd/Makefile
+===================================================================
+--- linux-2.6.22.1.orig/drivers/mtd/Makefile
++++ linux-2.6.22.1/drivers/mtd/Makefile
+@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT)     += mtdconcat.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR)                += mtdchar.o