get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt-10.03/.git] / target / linux / adm5120 / image / router_be.mk
index e9c1d40c85f3601bff408b965310d1b5c05ecfe5..5a166722fbc44ae75e565aabc23e9f9f1be93d2a 100644 (file)
@@ -6,11 +6,28 @@
 #
 
 define Image/Build/ZyXEL
+       $(call Image/Build/Loader,$(2),bin,0x80500000,0,y,$(2))
        $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
+       $(STAGING_DIR_HOST)/bin/mkzynfw -B $(2) \
+               -b $(KDIR)/loader-$(2).bin \
+               -r $(call imgname,$(1),$(2)).trx:0x10000 \
+               -o $(call imgname,$(1),$(2))-webui.bin
+endef
+
+define Image/Build/Template/ZyXEL
+       $(call Image/Build/ZyXEL,$(1),$(2))
+endef
+
+define Image/Build/Template/ZyXEL/squashfs
+       $(call Image/Build/Template/ZyXEL,squashfs,$(1))
+endef
+
+define Image/Build/Template/ZyXEL/jffs2
+       $(call Image/Build/Template/ZyXEL,jffs2,$(1))
 endef
 
 define Image/Build/Template/ZyXEL/Initramfs
-       $(call Image/Build/LZMAKernel/Admboot,$(1),gz)
+       $(call Image/Build/LZMAKernel/KArgs,$(1),bin)
 endef
 
 #