Rename 'refresh' to 'update' and make the new 'refresh' actually refresh all the...
[openwrt-10.03/.git] / target / linux / Makefile
index 9afda46c86015853077259c18771d2d414a88913..e1248691501fe0df3431c2e1096de435e543f00b 100644 (file)
@@ -7,18 +7,6 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-source:
-       $(MAKE) -C $(BOARD)-$(KERNEL) source
+clean download prepare compile install menuconfig update refresh: FORCE
+       $(MAKE) -C $(BOARD)-$(KERNEL) $@
 
-prepare:
-       rm -f $(TOPDIR)/.kernel.mk
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean