add second package source for packages built from the /packages repository
[openwrt-10.03/.git] / target / imagebuilder / files / Makefile
index 8b386a33c6c6e49f89bb4f7a5569e66f1db4d445..7dfc06c4c55d9f9356238376258c85a224f17470 100644 (file)
@@ -20,6 +20,7 @@ ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
 export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+export IMAGEBUILDER=1
 
 # override variables from rules.mk
 PACKAGE_DIR:=$(TOPDIR)/packages
@@ -136,7 +137,7 @@ package_postinst: FORCE
                for script in ./etc/init.d/*; do \
                        grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
                        IPKG_INSTROOT=$(BUILD_DIR)/root $(which bash) ./etc/rc.common $$script enable; \
-               done; \
+               done || true; \
        )
 
 build_image: FORCE