fix ipp2p
[openwrt-10.03/.git] / target / imagebuilder / files / Makefile
index 8b386a33c6c6e49f89bb4f7a5569e66f1db4d445..2e309ae730921ae9cf2ebded529411f60f70f7f8 100644 (file)
@@ -20,6 +20,7 @@ ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
 export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+export IMAGEBUILDER=1
 
 # override variables from rules.mk
 PACKAGE_DIR:=$(TOPDIR)/packages
@@ -47,7 +48,7 @@ define AddProfile
     endif
        $(ID)_NAME:=$(NAME)
        $(ID)_PACKAGES:=$(PACKAGES)
-    ifneq ($(KCONFIG),)
+    ifeq ($(KCONFIG),)
       PROFILE_LIST += \
                echo '$(ID):'; [ -z '$(NAME)' ] || echo '       $(NAME)'; echo '        Packages: $(PACKAGES)';
     endif
@@ -136,7 +137,7 @@ package_postinst: FORCE
                for script in ./etc/init.d/*; do \
                        grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
                        IPKG_INSTROOT=$(BUILD_DIR)/root $(which bash) ./etc/rc.common $$script enable; \
-               done; \
+               done || true; \
        )
 
 build_image: FORCE