last minute bugfixes
[openwrt-10.03/.git] / target / Makefile.in
index 15cf6bdedeee7eea1f4952c8be20524e235b4855..d40fd158d786a6072a6f572c53f6a9e31537d46b 100644 (file)
@@ -1,27 +1,18 @@
 # Default target skeleton stuff, may be overridden
-EXTRAVERSION=
+EXTRAVERSION:=
 TARGET_SKELETON=target/default/skel.tar.gz
 TARGET_SKEL_DIR=target/default/target_skeleton
 
 include target/device/Makefile.in
 
-ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
-JFFS2FLAGS+=-a 131072
-endif
-
-
 openwrt-linux.trx: openwrt-trx
        PATH=$(TARGET_PATH) trx -o openwrt-linux$(EXTRAVERSION).trx \
         $(LINUX_DIR)/$(LINUX_BINLOC) $(JFFS2FLAGS) $(IMAGE).$(ROOTFS)
 
-openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
+openwrt-code.bin: openwrt-addpattern openwrt-linux.trx
        PATH=$(TARGET_PATH) addpattern -2 -i  openwrt-linux$(EXTRAVERSION).trx \
-       -o openwrt-gs-code$(EXTRAVERSION).bin -g
-
-openwrt-g-code.bin: openwrt-gs-code.bin
-       sed -e "1s,^W54S,W54G," < openwrt-gs-code$(EXTRAVERSION).bin > openwrt-g-code$(EXTRAVERSION).bin
-
-openwrt-image: openwrt openwrt-g-code.bin
+       -o openwrt-$(TAG)-code$(EXTRAVERSION).bin -g
+       @$(SED) "1s,^W54S,$(TAG)," openwrt-$(TAG)-code$(EXTRAVERSION).bin
 
 openwrt-image-clean: 
        @-rm openwrt-* 2>/dev/null