Fix pfkey compile problem on 2.4 kernels.
[openwrt-10.03/.git] / package / yamonenv / Makefile
index dfb9bbb59ab8e116e53429ab003b63ea85e825a3..b26e071ce8b289ef526e3df4a08fb58ae6d372a2 100644 (file)
@@ -24,6 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/yamonenv
   SECTION:=utils
   CATEGORY:=Utilities
+  DEFAULT:=y if LINUX_2_6_AU1000
   DEPENDS:=@LINUX_2_6_AU1000@
   TITLE:=YAMON configuration utility
   URL:=http://meshcube.org/nylon/stable/sources/
@@ -33,7 +34,7 @@ define Build/Configure
 endef
 
 define Package/yamonenv/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
 endef