base-files: remove an old network tunable tweak which is messing up network stack...
[openwrt-10.03/.git] / package / wprobe / Makefile
index 786a39d124aa31c1f29b99eab4240ed7a961a705..aafe731dc04e801a2dbd7077fe1613539c96db21 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,6 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=wprobe
 PKG_VERSION:=1
+PKG_RELEASE:=1
 
 PKG_BUILD_DEPENDS:=PACKAGE_wprobe-export:libipfix
 
@@ -18,14 +19,19 @@ PKG_CONFIG_DEPENDS = \
 
 include $(INCLUDE_DIR)/package.mk
 
+# XXX: build failure on cris
+# wprobe-lib.c:145: error: 'packed' attribute ignored for field of type 'struct <anonymous>'
+# wprobe-lib.c:149: error: 'packed' attribute ignored for field of type 'struct <anonymous>'
+
 define Package/wprobe/Default
-  DEPENDS:=@LINUX_2_6 @(!(TARGET_ps3||TARGET_pxcab)||BROKEN)
+  DEPENDS:=@LINUX_2_6 @(!(TARGET_ps3||TARGET_pxcab||cris)||BROKEN)
 endef
 
 define KernelPackage/wprobe
 $(call Package/wprobe/Default)
   SUBMENU:=Network Support
   TITLE:=Wireless driver probe infrastructure
+  MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
   FILES:= \
        $(PKG_BUILD_DIR)/kernel/wprobe.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,01,wprobe)
@@ -61,6 +67,10 @@ define Package/wprobe-export/description
   wireless driver measurement data via the IPFIX protocol
 endef
 
+define Package/wprobe-export/conffiles
+/etc/config/wprobe
+endef
+
 define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
        $(CP) src/* $(PKG_BUILD_DIR)/