Add generic wpa_supplicant calls and use them for mac80211 and madwifi.
[openwrt-10.03/.git] / package / wpa_supplicant / Makefile
index 0a72572886a5e9462d4f3c894a8109d548adf7ec..ed6e45588e6bf66521974e1f6190c98ccfd3503b 100644 (file)
@@ -16,6 +16,8 @@ PKG_MD5SUM:=b51b2975f21006f85f7297f3fb1acde1
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
+PKG_BUILD_DEPENDS:=madwifi
+
 include $(INCLUDE_DIR)/package.mk
 STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_kmod-madwifi CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK)
 
@@ -23,6 +25,7 @@ define Package/wpa-supplicant
   SECTION:=net
   CATEGORY:=Network
   TITLE:=WPA Supplicant
+  DEPENDS:=$(if $(CONFIG_WPA_SUPPLICANT_OPENSSL),+libopenssl)
   URL:=http://hostap.epitest.fi/wpa_supplicant/
 endef
 
@@ -31,16 +34,9 @@ define Package/wpa-supplicant/Description
 endef
 
 define Package/wpa-supplicant/config
-  config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
-       bool "Disable timestamp check"
-       depends PACKAGE_wpa-supplicant
-       default n
-       help
-               This disables the timestamp check for certificates in wpa_supplicant
-               Useful for devices without RTC that cannot reliably get the real date/time
+       source "$(SOURCE)/Config.in"
 endef
 
-
 define Package/wpa-cli
   SECTION:=net
   CATEGORY:=Network
@@ -58,6 +54,7 @@ TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/madwifi $(if $(CONFIG_WPA_SUPPLICA
 define Build/Configure
        cp $(CONFIG) $(PKG_BUILD_DIR)/wpa_supplicant/.config
        $(if $(CONFIG_PACKAGE_kmod-madwifi),,$(SED) 's,^CONFIG_DRIVER_MADWIFI,#CONFIG_DRIVER_MADWIFI,g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
+       $(if $(CONFIG_WPA_SUPPLICANT_OPENSSL),$(SED) 's|^CONFIG_TLS.*|CONFIG_TLS=openssl|g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
 endef
 
 define Build/Compile
@@ -78,11 +75,13 @@ define Package/wpa-supplicant/install
                $(PKG_BUILD_DIR)/wpa_supplicant/wpa_supplicant \
                $(PKG_BUILD_DIR)/wpa_supplicant/wpa_passphrase \
                $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/lib/wifi
+       $(INSTALL_DATA) ./files/wpa_supplicant.sh $(1)/lib/wifi/wpa_supplicant.sh
 endef
 
 define Package/wpa-cli/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/wpa_cli $(1)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/wpa_supplicant/wpa_cli $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,wpa-supplicant))