add INCLUDE_DIR variable for $(TOPDIR)/include
[openwrt-10.03/.git] / package / wlcompat / Makefile
index c6dc6d894ff718bcd51bd90ac3bf4f58d2b79e68..e6ec27ee81fa3f5dc91fadd5974c9c1b87381aa0 100644 (file)
@@ -1,19 +1,20 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include $(TOPDIR)/package/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kmod-wlcompat
 PKG_RELEASE:=3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/kmod-wlcompat
 SECTION:=drivers
 CATEGORY:=Drivers
-DEPENDS:=
+DEPENDS:=kmod-brcm-wl
+DEFAULT:=y
 TITLE:=Wrapper providing Wireless Extensions for Broadcom wl module
 DESCRIPTION:= \\\
 A wrapper module, that provides Wireless Extension support for the \\\
@@ -23,6 +24,7 @@ endef
 
 define Package/kmod-wlcompat-debug
 $(call Package/kmod-wlcompat)
+DEFAULT:=m
 TITLE:=Wrapper providing Wireless Extensions for Broadcom wl module (debug)
 DESCRIPTION:= \\\
 A wrapper module, that provides Wireless Extension support for the \\\