add INCLUDE_DIR variable for $(TOPDIR)/include
[openwrt-10.03/.git] / package / wlcompat / Makefile
index 4c3632d98107dbab1016f58aea980eeae11ab83d..e6ec27ee81fa3f5dc91fadd5974c9c1b87381aa0 100644 (file)
@@ -1,23 +1,20 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kmod-wlcompat
 PKG_RELEASE:=3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
-include $(TOPDIR)/package/rules.mk
-
-WLCOMPAT_FLAGS:=$(TARGET_CFLAGS) -D__KERNEL__ -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \
-               -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 \
-               -Wa,-mips32 -Wa,--trap -DMODULE -mlong-calls -fno-common -I. -I linux-2.4 -funsigned-char -nostdinc \
-               -iwithprefix include -I$(LINUX_DIR)/include -I$(LINUX_DIR)/include/asm/gcc -I$(LINUX_DIR)/arch/mips/bcm947xx/include -I$(STAGING_DIR)/usr/include -I./src/include
+include $(INCLUDE_DIR)/package.mk
 
 define Package/kmod-wlcompat
 SECTION:=drivers
 CATEGORY:=Drivers
-DEPENDS:=
+DEPENDS:=kmod-brcm-wl
+DEFAULT:=y
 TITLE:=Wrapper providing Wireless Extensions for Broadcom wl module
 DESCRIPTION:= \\\
 A wrapper module, that provides Wireless Extension support for the \\\
@@ -27,15 +24,34 @@ endef
 
 define Package/kmod-wlcompat-debug
 $(call Package/kmod-wlcompat)
+DEFAULT:=m
 TITLE:=Wrapper providing Wireless Extensions for Broadcom wl module (debug)
 DESCRIPTION:= \\\
 A wrapper module, that provides Wireless Extension support for the \\\
 proprietary Broadcom wl module.
 endef
 
+define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
 define Build/Compile
-       $(TARGET_CC) -c -o $(PKG_BUILD_DIR)/wlcompat.o $(WLCOMPAT_FLAGS) wlcompat.c
-       $(TARGET_CC) -c -o $(PKG_BUILD_DIR)/wlcompat-debug.o $(WLCOMPAT_FLAGS) -DDEBUG wlcompat.c
+       $(MAKE) -C "$(LINUX_DIR)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               ARCH="$(LINUX_KARCH)" \
+               PATH="$(TARGET_PATH)" \
+               SUBDIRS="$(PKG_BUILD_DIR)" \
+               EXTRA_CFLAGS="-DDEBUG -I$(LINUX_DIR)/arch/mips/bcm947xx/include -I$(PKG_BUILD_DIR)/include" \
+               modules
+       mv $(PKG_BUILD_DIR)/wlcompat.o $(PKG_BUILD_DIR)/wlcompat-debug.o
+       $(MAKE) -C "$(LINUX_DIR)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               ARCH="$(LINUX_KARCH)" \
+               PATH="$(TARGET_PATH)" \
+               SUBDIRS="$(PKG_BUILD_DIR)" \
+               EXTRA_CFLAGS="-I$(LINUX_DIR)/arch/mips/bcm947xx/include -I$(PKG_BUILD_DIR)/include" \
+               modules
 endef
 
 define Package/kmod-wlcompat/install