video modules changes: change dependency on kmod-video-core from select to depends...
[openwrt-10.03/.git] / package / uvcvideo / Makefile
index c9c9f5ed3084d0263efbee1400e5eaa66e930e15..4aa9834a0050f64908acd16421eb7e46a7d71383 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -19,12 +19,11 @@ PKG_MD5SUM:=36c742d9dd1cf533fa059a1eeffa3e32
 
 include $(INCLUDE_DIR)/package.mk
 
-define KernelPackage/uvcvideo
-  SUBMENU:=USB Support
-  DEPENDS:=@LINUX_2_6 kmod-usb-core kmod-videodev @VIDEO_SUPPORT
-  TITLE:=Driver for Linux-UVC based USB cameras
+define KernelPackage/video-uvc
+  SUBMENU:=Video Support
+  TITLE:=USB Video Class (UVC) support
   URL:=http://linux-uvc.berlios.de/
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core
   FILES:=$(PKG_BUILD_DIR)/uvcvideo.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
 endef
@@ -33,11 +32,8 @@ define Build/Compile
        $(MAKE) -C $(LINUX_DIR) \
                ARCH="$(LINUX_KARCH)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
-               KERNELVERSION="$(KERNEL)" \
-               KERNEL_VERSION="$(LINUX_VERSION)" \
-               KERNELDIR="$(LINUX_DIR)" \
                SUBDIRS="$(PKG_BUILD_DIR)" \
                modules
 endef
 
-$(eval $(call KernelPackage,uvcvideo))
+$(eval $(call KernelPackage,video-uvc))