xfsprogs: fix compile errors with musl
[openwrt/.git] / package / utils / xfsprogs / Makefile
index a7a865a0eb5d7c9e56fe519a53062374e17ae0ca..81b44b389b2c9a4e6d1479cdbb71b9c9e119ff4a 100644 (file)
@@ -23,6 +23,7 @@ include $(INCLUDE_DIR)/nls.mk
 define Package/xfsprogs/default
   SECTION:=utils
   CATEGORY:=Utilities
+  SUBMENU:=Filesystem
   DEPENDS:=+libuuid +libpthread +librt
   URL:=http://oss.sgi.com/projects/xfs
 endef
@@ -44,7 +45,8 @@ endef
 
 CONFIGURE_ARGS += \
        --enable-gettext=no \
-       --enable-lib64=no
+       --enable-lib64=no \
+       --enable-blkid=no
 
 TARGET_CFLAGS += \
        -I$(STAGING_DIR)/usr/include \