mac80211: detect and drop incoming packets with invalid CCMP packet numbers to fix...
[openwrt-10.03/.git] / package / uhttpd / Makefile
index 3e7344911b5dc1bd957c7dccc547620439ca1090..9c0972818a785158cc0afb4dd80979084b0fa104 100644 (file)
@@ -8,9 +8,10 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=2
+PKG_RELEASE:=22
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+PKG_BUILD_DEPENDS := libcyassl liblua
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -56,6 +57,7 @@ endef
 
 # hack to use CyASSL headers
 TARGET_CFLAGS += -I$(firstword $(wildcard $(BUILD_DIR)/cyassl-*/include))
+TARGET_LDFLAGS += -lm
 MAKE_VARS += FPIC="$(FPIC)"
 
 define Build/Prepare
@@ -65,6 +67,8 @@ endef
 
 define Package/uhttpd/conffiles
 /etc/config/uhttpd
+/etc/uhttpd.crt
+/etc/uhttpd.key
 endef
 
 define Package/uhttpd/install