Add udev initilisation
[openwrt-10.03/.git] / package / udev / Makefile
index 4e00d6b7718a59bb881538b56b798b233f46b350..bde7a61e3d1ad685d32901cd08588cf2c65dd3bb 100644 (file)
@@ -13,12 +13,7 @@ PKG_VERSION:=106
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
-       http://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
-       ftp://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
-       http://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
-       ftp://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/ \
-       http://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/
+PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/hotplug/
 PKG_MD5SUM:=320ccd2d0f4540d10e021bafa14f8985
 
 include $(INCLUDE_DIR)/package.mk
@@ -28,15 +23,17 @@ define Package/udev
   CATEGORY:=Utilities
   DEPENDS:=@LINUX_2_6
   TITLE:=Dynamic device management subsystem
-  DESCRIPTION:=\
-       udev provides a dynamic device directory containing only the files for \\\
-       actually present devices. It creates or removes device node files in \\\
-       the /dev directory, or it renames network interfaces.
   URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
 endef
 
+define Package/udev/description
+ udev provides a dynamic device directory containing only the files for 
+ actually present devices. It creates or removes device node files in 
+ the /dev directory, or it renames network interfaces.
+endef
+
 define Package/udevtrigger
-  $(call Package/udev)
+$(call Package/udev)
   TITLE:=Small utility to request kernel devices events for coldplug
 endef
 
@@ -57,6 +54,7 @@ define Package/udev/install
        install -d -m0775 $(1)/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/sbin/udevsettle $(1)/sbin/
        install -d -m0775 $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/