ubox: add e2fsck support
[openwrt/.git] / package / system / ubox / Makefile
index 33bacc7536a821ea7925be42eb823a0318dc6464..84f55826a1925ede7bc6286fd2847f535584d723 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ubox
-PKG_VERSION:=2013-06-27
+PKG_VERSION:=2013-07-02
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/ubox.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=725444ad8dd42a6441499fae5a3e92dc99939cc1
+PKG_SOURCE_VERSION:=267dd987b1aec750f8839d1d8d8c2f80d9f1107e
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -24,7 +24,7 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
 define Package/ubox
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubusd +ubus +libuci +USE_EGLIBC:librt
+  DEPENDS:=+libubox +ubusd +ubus +libuci +USE_EGLIBC:librt
   TITLE:=OpenWrt system helper toolbox
 endef
 
@@ -32,7 +32,7 @@ define Package/block-mount
   SECTION:=base
   CATEGORY:=Base system
   TITLE:=Block device mounting and checking
-  DEPENDS:=+ubox
+  DEPENDS:=+ubox +libubox +libuci
   MENU:=1
 endef