only rebuild the package index when the *.ipk files have changed
[openwrt-10.03/.git] / package / switch / Makefile
index befae3410e40b94a7c178a570c41ffa33c741fc2..860e530c4c972c14cc27ba3d4a6f93d4cf4ad7d0 100644 (file)
@@ -1,4 +1,10 @@
-# $Id$
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id:$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -36,6 +42,10 @@ define Build/Compile
 endef
        
 define Package/kmod-switch/install
+       install -m0755 -d $(1)/lib/network/
+       install -m0755 ./files/switch.sh $(1)/lib/network/
+       install -m0755 -d $(1)/etc/modules.d/
+       printf 'switch-core\nswitch-robo\nswitch-adm\n' > $(1)/etc/modules.d/20-switch
        install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) $(PKG_BUILD_DIR)/*.$(LINUX_KMOD_SUFFIX) \
                $(1)/lib/modules/$(LINUX_VERSION)