Use shfs fixes from #1530, unmark as broken
[openwrt-10.03/.git] / package / shfs / Makefile
index ae99df39269a3ff325b2d4c412d3670a8ac97d8f..24bf094df863e3f32c38861383eb7acc36e7b943 100644 (file)
@@ -16,15 +16,10 @@ PKG_RELEASE:=2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/shfs
 PKG_MD5SUM:=016f49d71bc32eee2b5d11fc1600cfbe
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/shfs/Default
-  DEPENDS:=@BROKEN
   TITLE:=ShFS
   DESCRIPTION:=\
        ShFS is a simple and easy to use Linux kernel module which allows you to \\\
@@ -41,7 +36,7 @@ define KernelPackage/shfs
        \\\
        This package contains the ShFS kernel module.
   FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX)
-  SUBMENU:=Network Support
+  SUBMENU:=Filesystems
   VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   AUTOLOAD:=$(call AutoLoad,40,shfs)
 endef