[package] make robocfg work on brcm63xx as well (#4599)
[openwrt-10.03/.git] / package / robocfg / Makefile
index 072735ef6012aed9dce003bfb4751c15fd29a182..bfa1ef00207e0d649b0b745af11ed602587506a0 100644 (file)
@@ -17,9 +17,14 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/robocfg
 include $(INCLUDE_DIR)/package.mk
 
 define Package/robocfg
-SECTION:=base
-TITLE:=BCM5325E/536x switch configuration utility
-DESCRIPTION:=Broadcom BCM5325E/536x switch configuration utility
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=BCM5325E/536x switch configuration utility
+endef
+
+define Package/robocfg/description
+ This package contains an utility for configuring the Broadcom BCM5325E/536x 
+ based switches.
 endef
 
 define Build/Prepare
@@ -28,8 +33,8 @@ define Build/Prepare
 endef
 
 define Package/robocfg/install
-       install -d -m0755 $(1)/sbin
-       install -m0755 $(PKG_BUILD_DIR)/robocfg $(1)/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/robocfg $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,robocfg))