get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt-10.03/.git] / package / robocfg / Makefile
index 072735ef6012aed9dce003bfb4751c15fd29a182..4bc72f51db4e4a7f37b897a70d517e653a7784e9 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -17,9 +16,14 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/robocfg
 include $(INCLUDE_DIR)/package.mk
 
 define Package/robocfg
-SECTION:=base
-TITLE:=BCM5325E/536x switch configuration utility
-DESCRIPTION:=Broadcom BCM5325E/536x switch configuration utility
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=BCM5325E/536x switch configuration utility
+endef
+
+define Package/robocfg/description
+ This package contains an utility for configuring the Broadcom BCM5325E/536x 
+ based switches.
 endef
 
 define Build/Prepare
@@ -28,8 +32,8 @@ define Build/Prepare
 endef
 
 define Package/robocfg/install
-       install -d -m0755 $(1)/sbin
-       install -m0755 $(PKG_BUILD_DIR)/robocfg $(1)/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/robocfg $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,robocfg))