add file type autodetection for the unpack command and nuke PKG_CAT:= in lots of...
[openwrt-10.03/.git] / package / pptp / Makefile
index a07d6bdf64b01b5a74ea1ec8cf5a7b86e977698b..eb6652f008ce0b91b694fecc379e91a1e5d7af77 100644 (file)
@@ -1,50 +1,39 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptp
 PKG_VERSION:=1.6.0
-PKG_RELEASE:=1
-PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
+PKG_RELEASE:=3
 
-PKG_SOURCE_URL:=@SF/pptpclient
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
-
-$(DL_DIR)/$(PKG_SOURCE):
-        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
-
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       touch $(PKG_BUILD_DIR)/.unpacked
-
-$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.unpacked
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-        CC=$(TARGET_CC) \
-        CFLAGS="$(TARGET_CFLAGS)" \
-        all
-
-$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin
-       cp -a ./ipkg/* $(PKG_IPK_DIR)/
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       cp $(PKG_BUILD_DIR)/pptp $(PKG_IPK_DIR)/usr/sbin/
-       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       find $(PKG_IPK_DIR) -name CVS | xargs rm -rf
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/pptp.list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/pptp.list
+PKG_SOURCE_URL:=@SF/pptpclient
+PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
 
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pptp
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=PPTP client
+  DESCRIPTION:=\
+       This package contains a PPTP (Point-to-Point Tunneling Protocol) client.
+  URL:=http://pptpclient.sourceforge.net/
+endef
+
+define Package/pptp/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files/pptp.sh $(1)/lib/network/
+endef
+
+$(eval $(call BuildPackage,pptp))