add file type autodetection for the unpack command and nuke PKG_CAT:= in lots of...
[openwrt-10.03/.git] / package / pptp / Makefile
index 061e55395ebd143b332387ac05334d545468349a..eb6652f008ce0b91b694fecc379e91a1e5d7af77 100644 (file)
@@ -12,29 +12,28 @@ PKG_NAME:=pptp
 PKG_VERSION:=1.6.0
 PKG_RELEASE:=3
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/pptpclient
 PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
-PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pptp
-SECTION:=base
-# CATEGORY:=FIXME
-TITLE:=PPTP (Point-to-Point Tunneling Protocol) client
-DESCRIPTION:=A Point-to-Point Tunneling Protocol Client
-URL:=http://pptpclient.sourceforge.net/
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=PPTP client
+  DESCRIPTION:=\
+       This package contains a PPTP (Point-to-Point Tunneling Protocol) client.
+  URL:=http://pptpclient.sourceforge.net/
 endef
 
 define Package/pptp/install
-       install -d -m0755 $(1)/etc/ppp
-       install -m0644 ./files/options.pptp $(1)/etc/ppp/
-       install -d -m0755 $(1)/sbin
-       install -m0755 ./files/ifup.pptp $(1)/sbin/
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files/pptp.sh $(1)/lib/network/
 endef
 
 $(eval $(call BuildPackage,pptp))