remove Maintainer: and Source: from packages
[openwrt-10.03/.git] / package / pptp / Makefile
index b54b9d31d9858a5a7d432de53b0567705edf2bee..3334f23114204f7e4a82e609d31159d5eae7f3c7 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptp
 PKG_VERSION:=1.6.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
 
 PKG_SOURCE_URL:=@SF/pptpclient
@@ -18,18 +18,18 @@ include $(TOPDIR)/package/rules.mk
 $(eval $(call PKG_template,PPTP,pptp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
-       touch $(PKG_BUILD_DIR)/.configured
+       touch $@
 
 $(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC=$(TARGET_CC) \
                CFLAGS="$(TARGET_CFLAGS)" \
                all
-       touch $(PKG_BUILD_DIR)/.built
+       touch $@
 
 $(IPKG_PPTP):
-       install -d -m0755 $(IDIR_PPTP)/etc/init.d
-       install -m0755 ./files/pptp.init $(IDIR_PPTP)/etc/init.d/S50pptp
+       install -d -m0755 $(IDIR_PPTP)/sbin
+       install -m0755 ./files/ifup.pptp $(IDIR_PPTP)/sbin/ifup.pptp
        install -d -m0755 $(IDIR_PPTP)/etc/ppp
        install -m0644 ./files/options.pptp $(IDIR_PPTP)/etc/ppp/
        install -d -m0755 $(IDIR_PPTP)/usr/sbin