bump package versions after updates
[openwrt-10.03/.git] / package / pptp / Makefile
index 6c9f5150d92e1a89c77fca2ea3d21d8e5ef10179..2779dbf36ff13ec87bd05b7c50807c2032bc9dff 100644 (file)
@@ -1,38 +1,41 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptp
 PKG_VERSION:=1.6.0
-PKG_RELEASE:=1
-PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
+PKG_RELEASE:=4
 
-PKG_SOURCE_URL:=@SF/pptpclient
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,PPTP,pptp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               all
-       touch $@
+PKG_SOURCE_URL:=@SF/pptpclient
+PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
 
-$(IPKG_PPTP):
-       install -d -m0755 $(IDIR_PPTP)/etc/init.d
-       install -m0755 ./files/pptp.init $(IDIR_PPTP)/etc/init.d/S50pptp
-       install -d -m0755 $(IDIR_PPTP)/etc/ppp
-       install -m0644 ./files/options.pptp $(IDIR_PPTP)/etc/ppp/
-       install -d -m0755 $(IDIR_PPTP)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/pptp $(IDIR_PPTP)/usr/sbin/
-       $(RSTRIP) $(IDIR_PPTP)
-       $(IPKG_BUILD) $(IDIR_PPTP) $(PACKAGE_DIR)
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pptp
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=PPTP client
+  URL:=http://pptpclient.sourceforge.net/
+endef
+
+define Package/pptp/daemon
+ This package contains a PPTP (Point-to-Point Tunneling Protocol) client.
+endef
+
+define Package/pptp/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files/pptp.sh $(1)/lib/network/
+endef
+
+$(eval $(call BuildPackage,pptp))