add INCLUDE_DIR variable for $(TOPDIR)/include
[openwrt-10.03/.git] / package / pptp / Makefile
index 870341c87d2ad2bc2ba669807532cb0b7c49125e..0478b4c2b88ad999218645132670574117ed4ce4 100644 (file)
@@ -5,34 +5,30 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=pptp
 PKG_VERSION:=1.6.0
 PKG_RELEASE:=3
-PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
 
-PKG_SOURCE_URL:=@SF/pptpclient
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/pptpclient
+PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
 PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,PPTP,pptp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               all
-       touch $@
-
-$(IPKG_PPTP):
-       install -d -m0755 $(IDIR_PPTP)/sbin
-       install -m0755 ./files/ifup.pptp $(IDIR_PPTP)/sbin/ifup.pptp
-       install -d -m0755 $(IDIR_PPTP)/etc/ppp
-       install -m0644 ./files/options.pptp $(IDIR_PPTP)/etc/ppp/
-       install -d -m0755 $(IDIR_PPTP)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/pptp $(IDIR_PPTP)/usr/sbin/
-       $(RSTRIP) $(IDIR_PPTP)
-       $(IPKG_BUILD) $(IDIR_PPTP) $(PACKAGE_DIR)
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pptp
+SECTION:=base
+# CATEGORY:=FIXME
+TITLE:=PPTP (Point-to-Point Tunneling Protocol) client
+DESCRIPTION:=A Point-to-Point Tunneling Protocol Client
+URL:=http://pptpclient.sourceforge.net/
+endef
+
+define Package/pptp/install
+       install -d -m0755 $(1)/etc/ppp
+       install -m0644 ./files/options.pptp $(1)/etc/ppp/
+       install -d -m0755 $(1)/sbin
+       install -m0755 ./files/ifup.pptp $(1)/sbin/
+       install -d -m0755 $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,pptp))