add INCLUDE_DIR variable for $(TOPDIR)/include
[openwrt-10.03/.git] / package / pptp / Makefile
index 0ddd247dc6536bcd88e713192717c01a69fb87da..0478b4c2b88ad999218645132670574117ed4ce4 100644 (file)
@@ -1,50 +1,34 @@
-#############################################################
-#
-# pptp client
-#
-#############################################################
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptp
 PKG_VERSION:=1.6.0
-PKG_RELEASE:=1
-PKG_SOURCE_URL:=@SF/pptpclient
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_RELEASE:=3
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/pptpclient
+PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
-
-$(DL_DIR)/$(PKG_SOURCE):
-        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) x $(PKG_SOURCE_URL)
-
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       touch $(PKG_BUILD_DIR)/.unpacked
-
-$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.unpacked
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-        CC=$(TARGET_CC) \
-        CFLAGS="$(TARGET_CFLAGS)" \
-        all
-
-$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin
-       cp -a ./ipkg/* $(PKG_IPK_DIR)/
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       cp $(PKG_BUILD_DIR)/pptp $(PKG_IPK_DIR)/usr/sbin/
-       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/pptp.list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/pptp.list
 
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pptp
+SECTION:=base
+# CATEGORY:=FIXME
+TITLE:=PPTP (Point-to-Point Tunneling Protocol) client
+DESCRIPTION:=A Point-to-Point Tunneling Protocol Client
+URL:=http://pptpclient.sourceforge.net/
+endef
+
+define Package/pptp/install
+       install -d -m0755 $(1)/etc/ppp
+       install -m0644 ./files/options.pptp $(1)/etc/ppp/
+       install -d -m0755 $(1)/sbin
+       install -m0755 ./files/ifup.pptp $(1)/sbin/
+       install -d -m0755 $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,pptp))