add missing MMC config symbol
[openwrt-10.03/.git] / package / p54 / Makefile
index c69bfd607482bb8c3ab2eda2d95f767732a62eac..c282a09bf11e5292f2d2d9a23a228bd6583c93bb 100644 (file)
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/p54/Default
   SUBMENU:=Wireless Drivers
   TITLE:=Prism Wireless Support (mac80211)
-  DEPENDS:=@LINUX_2_6 +kmod-mac80211
+  DEPENDS:=+kmod-mac80211 @!TARGET_atheros @!TARGET_uml
 endef
 
 define KernelPackage/p54-common
@@ -95,7 +95,9 @@ ifneq ($(findstring 2.6.23,$(LINUX_VERSION)),)
                modules
   endef
 else
-  override CONFIG_kmod-p54=
+  override CONFIG_PACKAGE_kmod-p54-common=
+  override CONFIG_PACKAGE_kmod-p54-pci=
+  override CONFIG_PACKAGE_kmod-p54-usb=
 endif
 
 define KernelPackage/p54-pci/install