Invert logic, first search for find as most people will build under Linux
[openwrt-10.03/.git] / package / opkg / Makefile
index ab41ac09954f05c3746574172767749c74db292e..76729db7b1271c447bb27d0da1870edb73c2af0b 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opkg
-PKG_REV:=4561
+PKG_REV:=4564
 PKG_VERSION:=$(PKG_REV)
 PKG_RELEASE:=1
 
@@ -22,7 +22,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/opkg
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+libcurl
   TITLE:=opkg package management system
   URL:=http://wiki.openmoko.org/wiki/Opkg
 endef
@@ -37,6 +36,7 @@ define Package/opkg/description
   opkg knows how to install both .ipk and .deb packages.
 endef
 
+TARGET_CFLAGS += $(FPIC)
 EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib
 EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
 
@@ -46,7 +46,7 @@ CONFIGURE_ARGS += \
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
-               ./autogen.sh \
+               autoreconf -v --install || exit 1 \
        );
        $(call Build/Configure/Default)
 endef
@@ -59,9 +59,6 @@ define Build/Compile
 endef
 
 define Package/opkg/install
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) ./files/opkg.conf $(1)/etc/ 
-       $(SED) 's,$$$$S,$(BOARD),g' $(1)/etc/opkg.conf
        $(INSTALL_BIN) ./files/postinst $(1)/CONTROL/postinst
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg