modernize backfire 10.03 so it can be operational again
[openwrt-10.03/.git] / package / opkg / Makefile
index 491d52e43208e7f9e2b9f6130af18ca20c83fa80..1ab2796a22a6b66f0809276c3ea40c79b18205e1 100644 (file)
@@ -1,14 +1,15 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=opkg
-PKG_REV:=503
+PKG_REV:=576
 PKG_VERSION:=$(PKG_REV)
 PKG_RELEASE:=2
 
@@ -17,13 +18,17 @@ PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
-PKG_FIXUP = libtool
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES = autogen.sh aclocal.m4
+
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/opkg
   SECTION:=base
   CATEGORY:=Base system
   TITLE:=opkg package management system
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   URL:=http://wiki.openmoko.org/wiki/Opkg
 endef
 
@@ -47,14 +52,8 @@ EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 CONFIGURE_ARGS += \
        --disable-curl \
        --disable-gpg \
-       --with-ipkgetcdir=/etc
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-               autoreconf -v --install || exit 1 \
-       );
-       $(call Build/Configure/Default)
-endef
+       --with-opkgetcdir=/etc \
+       --with-opkglockfile=/var/lock/opkg.lock
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -69,7 +68,7 @@ define Package/opkg/install
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/opkg.conf $(1)/etc/
-       $(SED) 's,$$$$S,$(PKGARCH),g' $(1)/etc/opkg.conf
+       $(VERSION_SED) $(1)/etc/opkg.conf
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
 endef
 
@@ -78,4 +77,20 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libopkg $(1)/usr/include/
 endef
 
+
+HOST_CONFIGURE_ARGS+= \
+       --disable-curl \
+       --disable-gpg \
+       --with-opkgetcdir=/etc \
+       --with-opkglockfile=/tmp/opkg.lock
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/opkg-cl $(STAGING_DIR_HOST)/bin/opkg
+endef
+
 $(eval $(call BuildPackage,opkg))
+$(eval $(call HostBuild))