[package] openssl: update to 0.9.8j. thanks puchu.
[openwrt-10.03/.git] / package / openssl / patches / 160-disable_doc_tests.patch
index 27e203347552e745c36aabe011677c6445d29770..07c8e576bd21b5e570726099bdcbb3be5cae8ede 100644 (file)
@@ -1,16 +1,16 @@
-diff -urN openssl-0.9.8a/Makefile openssl-0.9.8a.new/Makefile
---- openssl-0.9.8a/Makefile    2005-10-11 12:21:48.000000000 +0200
-+++ openssl-0.9.8a.new/Makefile        2006-03-29 15:23:28.107586680 +0200
-@@ -102,7 +102,7 @@
- KRB5_INCLUDES=
- LIBKRB5=
--DIRS=   crypto ssl engines apps test tools
-+DIRS=   crypto ssl engines apps tools
+diff -burN openssl-0.9.8j/Makefile openssl-0.9.8j.patched/Makefile
+--- openssl-0.9.8j/Makefile    2009-01-07 12:57:01.000000000 +0100
++++ openssl-0.9.8j.patched/Makefile    2009-01-17 14:16:50.279667198 +0100
+@@ -133,7 +133,7 @@
+ BASEADDR=0xFB00000
+-DIRS=   crypto fips ssl engines apps test tools
++DIRS=   crypto fips ssl engines apps tools
  SHLIBDIRS= crypto ssl
  
  # dirs in crypto to build
-@@ -119,7 +119,7 @@
+@@ -150,7 +150,7 @@
  
  # tests to perform.  "alltests" is a special word indicating that all tests
  # should be performed.
@@ -19,7 +19,7 @@ diff -urN openssl-0.9.8a/Makefile openssl-0.9.8a.new/Makefile
  
  MAKEFILE= Makefile
  
-@@ -131,7 +131,7 @@
+@@ -162,7 +162,7 @@
  
  TOP=    .
  ONEDIRS=out tmp
@@ -28,16 +28,16 @@ diff -urN openssl-0.9.8a/Makefile openssl-0.9.8a.new/Makefile
  WDIRS=  windows
  LIBS=   libcrypto.a libssl.a
  SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
-@@ -204,7 +204,7 @@
-       @[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
+@@ -321,7 +321,7 @@
+       ../crypto/uid.o
  
  sub_all: build_all
 -build_all: build_libs build_apps build_tests build_tools
 +build_all: build_libs build_apps build_tools
  
- build_libs: build_crypto build_ssl build_engines
+ build_libs: build_crypto build_fips build_ssl build_shared build_engines
  
-@@ -454,7 +454,7 @@
+@@ -610,7 +610,7 @@
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
@@ -46,10 +46,10 @@ diff -urN openssl-0.9.8a/Makefile openssl-0.9.8a.new/Makefile
  
  install_sw:
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
-diff -urN openssl-0.9.8b/Makefile.org openssl-0.9.8b.new/Makefile.org
---- openssl-0.9.8b/Makefile.org        2006-09-01 19:34:51.000000000 +0200
-+++ openssl-0.9.8b.new/Makefile.org    2006-09-01 19:36:38.000000000 +0200
-@@ -473,7 +473,7 @@
+diff -burN openssl-0.9.8j/Makefile.org openssl-0.9.8j.patched/Makefile.org
+--- openssl-0.9.8j/Makefile.org        2008-12-30 14:26:26.000000000 +0100
++++ openssl-0.9.8j.patched/Makefile.org        2009-01-17 14:14:18.874409981 +0100
+@@ -608,7 +608,7 @@
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)