wwan: check new uci bus option on proto setup event
[openwrt/.git] / package / network / utils / wwan / Makefile
index 10479d1ac11424cf4c2c5aa5d5ab15351302bb25..16291de0b15766178795654c699a6b12d1eabe3f 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wwan
-PKG_VERSION:=2014-07-17
+PKG_VERSION:=2019-04-29
 PKG_RELEASE=1
 
 PKG_LICENSE:=GPL-2.0
@@ -30,6 +30,16 @@ define Package/wwan/install
        $(INSTALL_BIN) ./files/wwan.usbmisc $(1)/etc/hotplug.d/usbmisc/00_wwan.sh
        $(INSTALL_DIR) $(1)/lib/network/wwan/
        $(INSTALL_DATA) ./files/data/* $(1)/lib/network/wwan/
+       #in order to keep the Lede GIT repo free of filenames with colons,
+       #we name the files xxxx-yyyy
+       # and rename here after copying to the build directory
+       shopt -s nullglob ; \
+       for filevar in $(1)/lib/network/wwan/*-* ; \
+       do \
+               FILENAME=$$$$(basename $$$$filevar) ; \
+               NEWNAME=$$$${FILENAME//-/:} ; \
+               mv "$(1)/lib/network/wwan/$$$$FILENAME" "$(1)/lib/network/wwan/$$$$NEWNAME" ; \
+       done
 endef
 
 $(eval $(call BuildPackage,wwan))