remove automake prereq not needed anymore since [7011], use a separate description...
[openwrt-10.03/.git] / package / linux-atm / Makefile
index 3fe9dd0c9deb47f5d4f7d1168bdfeb04ce50e4d0..f7d52141f38448c19344241902a39394b1d720d9 100644 (file)
@@ -18,27 +18,15 @@ PKG_MD5SUM:=84fef49cc39ff2605204246666f65864
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/linux-atm/Default
-  URL:=http://linux-atm.sourceforge.net/
-endef
-
 define Package/linux-atm
-  $(call Package/linux-atm/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=Linux ATM Library
-  DESCRIPTION:=\
-       This package contains a library for accessing the Linux ATM subsystem.
+  TITLE:=Linux ATM library
+  URL:=http://linux-atm.sourceforge.net/
 endef
 
-define Package/br2684ctl
-  $(call Package/linux-atm/Default)
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+linux-atm
-  TITLE:=RFC2684 bridging utility
-  DESCRIPTION:=\
-       This package contains an ATM RFC2684 bridging utility.
+define Package/linux-atm/description
+  This package contains a library for accessing the Linux ATM subsystem.
 endef
 
 define Build/Configure
@@ -74,16 +62,4 @@ define Package/linux-atm/install
        cp -f $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1 $(1)/usr/lib
 endef
 
-define Package/br2684ctl/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/net
-       $(INSTALL_DATA) ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
-endef
-
 $(eval $(call BuildPackage,linux-atm))
-$(eval $(call BuildPackage,br2684ctl))
-
-$(eval $(call RequireCommand,automake, \
-       $(PKG_NAME) requires automake. \
-))