reorganize/rationalize/format package menuconfig,
[openwrt-10.03/.git] / package / libtool / Makefile
index 3bfc7514c28fb750e44237775dc8fec65fb5919c..ac74a25e9f540f10b226f84bf3938ba8e8a45b7b 100644 (file)
@@ -7,7 +7,10 @@ PKG_VERSION:=1.5.14
 PKG_RELEASE:=1
 PKG_MD5SUM:=049bf67de9b0eb75cd943dafe3d749ec
 
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/libtool/
+PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/libtool/ \
+       ftp://ftp.belnet.be/mirror/ftp.gnu.org/gnu/libtool/ \
+       ftp://ftp.mirror.nl/pub/mirror/gnu/libtool/ \
+       http://mirror.switch.ch/ftp/mirror/gnu/libtool/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
@@ -18,7 +21,7 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,LIBLTDL,libltdl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -47,7 +50,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        );
        touch $@
 
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -66,12 +69,14 @@ $(STAGING_DIR)/usr/lib/libltdl.so: $(PKG_BUILD_DIR)/.built
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/ltdl.h $(STAGING_DIR)/usr/include/
        mkdir -p $(I_LIBLTDL_DEV)/usr/lib
        cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libltdl.{a,so*} $(STAGING_DIR)/usr/lib/
+       touch $@
 
 install-dev: $(STAGING_DIR)/usr/lib/libltdl.so
 
 uninstall-dev:
-       rm -rf $(STAGING_DIR)/usr/include/ltdl*
-       rm -rf $(STAGING_DIR)/usr/lib/libltdl.{a,so*}
+       rm -rf \
+               $(STAGING_DIR)/usr/include/ltdl.h \
+               $(STAGING_DIR)/usr/lib/libltdl.{a,so*} \
 
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev