firewall: introduce drop_invalid option to allow disabling the invalid state match
[openwrt-10.03/.git] / package / libnl / Makefile
index f55d494a6360cb37fa5a3823a09e906566077da7..b17bc09f28dd22fa97f02533c7c08f4f22762c5b 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl
 PKG_VERSION:=1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://people.suug.ch/~tgr/libnl/files/
@@ -29,6 +29,8 @@ define Package/libnl/description
  This package contains a library for applications dealing with netlink sockets
 endef
 
+TARGET_CFLAGS += -ffunction-sections $(FPIC)
+
 define Build/Compile
        $(call Build/Compile/Default)
        make -C $(PKG_BUILD_DIR) \
@@ -36,7 +38,7 @@ define Build/Compile
                install
 endef
 
-ifneq ($(CONFIG_LINUX_2_6_23)$(CONFIG_LINUX_2_6_24),)
+ifneq ($(CONFIG_LINUX_2_6),)
   define Build/InstallDev
        $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
@@ -46,7 +48,7 @@ ifneq ($(CONFIG_LINUX_2_6_23)$(CONFIG_LINUX_2_6_24),)
 
   define Package/libnl/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.* $(1)/usr/lib/
   endef
 endif