move package description to a separate definition, remove it when DESCRIPTION=TITLE
[openwrt-10.03/.git] / package / kexec-tools / Makefile
index d88fc0583ccef2f6b758842f29b451ce26736179..d31aeaa856b145da370f68a32a60c628565ad521 100644 (file)
@@ -15,28 +15,26 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.xmission.com/~ebiederm/files/kexec/
 PKG_MD5SUM:=b4f7ffcc294d41a6a4c40d6e44b7734d
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/kexec-tools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6_X86 zlib
+  DEPENDS:=@i386 +zlib
   TITLE:=Kernel boots kernel
-  DESCRIPTION:=\
-       kexec is a set of systems call that allows you to load \\\
-       another kernel from the currently executing Linux kernel.
   URL:=http://www.xmission.com/~ebiederm/files/kexec/README
 endef
 
+define Package/kexec-tools/description
+ kexec is a set of systems call that allows you to load 
+ another kernel from the currently executing Linux kernel.
+endef
+
 MAKE_FLAGS += \
        DESTDIR="$(PKG_INSTALL_DIR)" \
        EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
-       BUILD_CFLAGS="-O2" \
+       BUILD_CFLAGS="-Os" \
        LIBS="$(TARGET_LDFLAGS) -lz" \
        install