move package description to a separate definition, remove it when DESCRIPTION=TITLE
[openwrt-10.03/.git] / package / kexec-tools / Makefile
index cfca8b1dccd3f35402e142dfd46b3e733ef3d771..d31aeaa856b145da370f68a32a60c628565ad521 100644 (file)
@@ -21,18 +21,20 @@ include $(INCLUDE_DIR)/package.mk
 define Package/kexec-tools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6_X86 +zlib
+  DEPENDS:=@i386 +zlib
   TITLE:=Kernel boots kernel
-  DESCRIPTION:=\
-       kexec is a set of systems call that allows you to load \\\
-       another kernel from the currently executing Linux kernel.
   URL:=http://www.xmission.com/~ebiederm/files/kexec/README
 endef
 
+define Package/kexec-tools/description
+ kexec is a set of systems call that allows you to load 
+ another kernel from the currently executing Linux kernel.
+endef
+
 MAKE_FLAGS += \
        DESTDIR="$(PKG_INSTALL_DIR)" \
        EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
-       BUILD_CFLAGS="-O2" \
+       BUILD_CFLAGS="-Os" \
        LIBS="$(TARGET_LDFLAGS) -lz" \
        install