Allow kexec to directly use the kernel exposed in a mtd partition and reboot using...
[openwrt-10.03/.git] / package / kexec-tools / Makefile
index cfca8b1dccd3f35402e142dfd46b3e733ef3d771..6274cb81c3240b0d0c985b1b089ca3ce2acd45e5 100644 (file)
@@ -21,18 +21,20 @@ include $(INCLUDE_DIR)/package.mk
 define Package/kexec-tools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6_X86 +zlib
+  DEPENDS:=@i386 +zlib
   TITLE:=Kernel boots kernel
-  DESCRIPTION:=\
-       kexec is a set of systems call that allows you to load \\\
-       another kernel from the currently executing Linux kernel.
   URL:=http://www.xmission.com/~ebiederm/files/kexec/README
 endef
 
+define Package/kexec-tools/description
+ kexec is a set of systems call that allows you to load 
+ another kernel from the currently executing Linux kernel.
+endef
+
 MAKE_FLAGS += \
        DESTDIR="$(PKG_INSTALL_DIR)" \
        EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
-       BUILD_CFLAGS="-O2" \
+       BUILD_CFLAGS="-Os" \
        LIBS="$(TARGET_LDFLAGS) -lz" \
        install
 
@@ -46,6 +48,7 @@ define Package/kexec-tools/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kexec $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kdump $(1)/usr/bin/
+       $(INSTALL_BIN) ./files/kexec.sh $(1)/usr/bin/kexec.mtd
 endef
 
 $(eval $(call BuildPackage,kexec-tools))