[ps3] add missing kconfig option to ps3 sound module
[openwrt-10.03/.git] / package / kernel / modules / sound.mk
index 5146bf4693a3a5fad7389e2257806fe16690f182..f78cdfc4bc936f72f8bfaf84e4f8121f10760fda 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 SOUND_MENU:=Sound Support
 
@@ -96,9 +95,10 @@ $(eval $(call KernelPackage,sound-i8x0))
 define KernelPackage/sound-ps3
   SUBMENU:=$(SOUND_MENU)
   TITLE:=PS3 Audio
-  DEPENDS:=kmod-sound-core
+  DEPENDS:=kmod-sound-core @TARGET_ps3
   KCONFIG:=CONFIG_SND_PS3 \
-               CONFIG_SND_PPC
+               CONFIG_SND_PPC=y \
+               CONFIG_SND_PS3_DEFAULT_START_DELAY=2000
   FILES:=$(LINUX_DIR)/sound/ppc/snd_ps3.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,35, snd_ps3)
 endef