[backfire] package IFB kernel module (#8849)
[openwrt-10.03/.git] / package / kernel / modules / sound.mk
index e4a4c73cfbe0fa525a625c0cd9b630a5be16eebc..a3d1486346e1305c171d4fedc0efe194539cfc3f 100644 (file)
@@ -10,7 +10,7 @@ SOUND_MENU:=Sound Support
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@AUDIO_SUPPORT
+  DEPENDS:=@AUDIO_SUPPORT +!TARGET_x86:kmod-input-core
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
@@ -141,7 +141,7 @@ $(call KernelPackage/sound/Depends)
        CONFIG_SND_SOC \
        CONFIG_SND_SOC_ALL_CODECS=n
   FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
-  AUTOLOAD:=$(call AutoLoad,35, snd-soc-core)
+  AUTOLOAD:=$(call AutoLoad,55, snd-soc-core)
 endef
 
 $(eval $(call KernelPackage,sound-soc-core))