move CAPI/ISDN module from other.mk to network.mk
[openwrt-10.03/.git] / package / kernel / modules / other.mk
index 79af470e4cd924b5fec3c0a57b757ae932376b91..5cdc73ef63d6c486b6d88e01a96a79617a995300 100644 (file)
@@ -156,57 +156,6 @@ endef
 $(eval $(call KernelPackage,soundcore))
 
 
-define KernelPackage/loop
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Loopback device support
-  KCONFIG:=CONFIG_BLK_DEV_LOOP
-  FILES:=$(LINUX_DIR)/drivers/block/loop.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,loop)
-endef
-
-define KernelPackage/loop/description
- Kernel module for loopback device support
-endef
-
-$(eval $(call KernelPackage,loop))
-
-
-define KernelPackage/nbd
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Network block device support
-  KCONFIG:=CONFIG_BLK_DEV_NBD
-  FILES:=$(LINUX_DIR)/drivers/block/nbd.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,nbd)
-endef
-
-define KernelPackage/nbd/description
- Kernel module for network block device support
-endef
-
-$(eval $(call KernelPackage,nbd))
-
-
-define KernelPackage/capi
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=CAPI Support
-  DEPENDS:=@LINUX_2_6
-  KCONFIG:= \
-       CONFIG_ISDN \
-       CONFIG_ISDN_CAPI \
-       CONFIG_ISDN_CAPI_CAPI20
-  FILES:= \
-       $(LINUX_DIR)/drivers/isdn/capi/kernelcapi.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/isdn/capi/capi.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,kernelcapi capi)
-endef
-
-define KernelPackage/capi/description
- Kernel module for basic CAPI support
-endef
-
-$(eval $(call KernelPackage,capi))
-
-
 define KernelPackage/pcmcia-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PCMCIA/CardBus support
@@ -417,6 +366,22 @@ endef
 $(eval $(call KernelPackage,leds-net48xx))
 
 
+define KernelPackage/leds-wrap
+  SUBMENU:=$(EMENU)
+  TITLE:=PCengines WRAP LED support
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_LEDS_WRAP
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-wrap.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,leds-wrap)
+endef
+
+define KernelPackage/leds-wrap/description
+ Kernel module for PCengines WRAP LEDs
+endef
+
+$(eval $(call KernelPackage,leds-wrap))
+
+
 define KernelPackage/nsc-gpio
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Natsemi GPIO support