[package] package nls cp866 support (#6281)
[openwrt-10.03/.git] / package / kernel / modules / fs.mk
index 7f3ed0c94148ebaf5549949ae35c0d9e2cd40592..768ee4b6e1be235f1647f798bab83da5218caf5c 100644 (file)
@@ -4,14 +4,11 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 FS_MENU:=Filesystems
 
 define KernelPackage/nls/Depends
-  ifneq ($(KERNEL),2.4)
-    DEPENDS:= +kmod-nls-base
-  endif
+  DEPENDS:= +!LINUX_2_4:kmod-nls-base
 endef
 
 define KernelPackage/fs-cifs
@@ -52,6 +49,7 @@ define KernelPackage/fs-ntfs
   KCONFIG:=CONFIG_NTFS_FS
   FILES:=$(LINUX_DIR)/fs/ntfs/ntfs.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,ntfs)
+$(call KernelPackage/nls/Depends)
 endef
 
 define KernelPackage/fs-ntfs/description
@@ -84,7 +82,7 @@ define KernelPackage/fs-ext2
   KCONFIG:=CONFIG_EXT2_FS
   DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
   FILES:=$(LINUX_DIR)/fs/ext2/ext2.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,ext2)
+  AUTOLOAD:=$(call AutoLoad,32,ext2)
 endef
 
 define KernelPackage/fs-ext2/description
@@ -104,7 +102,7 @@ define KernelPackage/fs-ext3
   FILES:= \
        $(LINUX_DIR)/fs/ext3/ext3.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/fs/jbd/jbd.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,jbd ext3)
+  AUTOLOAD:=$(call AutoLoad,31,jbd ext3)
 endef
 
 define KernelPackage/fs-ext3/description
@@ -113,6 +111,36 @@ endef
 
 $(eval $(call KernelPackage,fs-ext3))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,2.6.28)),1)
+       EXT4_NAME:=ext4dev
+else
+       EXT4_NAME:=ext4
+endif
+
+define KernelPackage/fs-ext4
+  SUBMENU:=$(FS_MENU)
+  TITLE:=EXT4 filesystem support
+  KCONFIG:= \
+       CONFIG_EXT4DEV_COMPAT=y \
+       CONFIG_EXT4_FS_XATTR=y \
+       CONFIG_EXT4_FS_POSIX_ACL=y \
+       CONFIG_EXT4_FS_SECURITY=y \
+       CONFIG_EXT4_FS \
+       CONFIG_JBD2
+  DEPENDS:= @LINUX_2_6 +kmod-crc16 $(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
+  FILES:= \
+       $(LINUX_DIR)/fs/ext4/$(EXT4_NAME).$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/fs/jbd2/jbd2.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,jbd2 $(EXT4_NAME))
+endef
+
+define KernelPackage/fs-ext4/description
+ Kernel module for EXT4 filesystem support
+endef
+
+$(eval $(call KernelPackage,fs-ext4))
+
+
 
 define KernelPackage/fs-hfs
   SUBMENU:=$(FS_MENU)
@@ -192,13 +220,19 @@ define KernelPackage/fs-nfs-common
   AUTOLOAD:=$(call AutoLoad,30,sunrpc lockd)
 endef
 
+define KernelPackage/fs-nfs-common/2.6
+  KCONFIG+=CONFIG_SUNRPC_GSS
+  FILES+=$(LINUX_DIR)/net/sunrpc/auth_gss/auth_rpcgss.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD=$(call AutoLoad,30,sunrpc lockd auth_rpcgss)
+endef
+
 $(eval $(call KernelPackage,fs-nfs-common))
 
 
 define KernelPackage/fs-nfs
   SUBMENU:=$(FS_MENU)
   TITLE:=NFS filesystem support
-  DEPENDS:=kmod-fs-nfs-common
+  DEPENDS:=+kmod-fs-nfs-common
   KCONFIG:= \
        CONFIG_NFS_FS
   FILES:= \
@@ -213,23 +247,30 @@ endef
 $(eval $(call KernelPackage,fs-nfs))
 
 
+define KernelPackage/fs-exportfs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=exportfs kernel server support
+  KCONFIG:=CONFIG_EXPORTFS
+  FILES=$(LINUX_DIR)/fs/exportfs/exportfs.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,20,exportfs)
+endef
+
+define KernelPackage/fs-exportfs/description
+ Kernel module for exportfs. Needed for some other modules.
+endef
+
+$(eval $(call KernelPackage,fs-exportfs))
+
+
 define KernelPackage/fs-nfsd
   SUBMENU:=$(FS_MENU)
   TITLE:=NFS kernel server support
-  DEPENDS:=kmod-fs-nfs-common
+  DEPENDS:=+kmod-fs-nfs-common +kmod-fs-exportfs
   KCONFIG:=CONFIG_NFSD
   FILES:=$(LINUX_DIR)/fs/nfsd/nfsd.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,40,nfsd)
 endef
 
-define KernelPackage/fs-nfsd/2.6
-  KCONFIG+=CONFIG_EXPORTFS \
-       CONFIG_SUNRPC_GSS
-  FILES+=$(LINUX_DIR)/fs/exportfs/exportfs.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/net/sunrpc/auth_gss/auth_rpcgss.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD+=$(call AutoLoad,40,auth_rpcgss exportfs nfsd)
-endef
-
 define KernelPackage/fs-nfsd/description
  Kernel module for NFS kernel server support
 endef
@@ -273,6 +314,10 @@ endef
 
 $(eval $(call KernelPackage,fs-reiserfs))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),1)
+  VFAT_DIR:=fat
+endif
+VFAT_DIR?=vfat
 
 define KernelPackage/fs-vfat
   SUBMENU:=$(FS_MENU)
@@ -282,7 +327,7 @@ define KernelPackage/fs-vfat
        CONFIG_VFAT_FS
   FILES:= \
        $(LINUX_DIR)/fs/fat/fat.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/fs/$(if $(CONFIG_LINUX_2_6_28),fat,vfat)/vfat.$(LINUX_KMOD_SUFFIX)
+       $(LINUX_DIR)/fs/$(VFAT_DIR)/vfat.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,fat vfat)
 $(call KernelPackage/nls/Depends)
 endef
@@ -299,6 +344,7 @@ define KernelPackage/fs-xfs
   SUBMENU:=$(FS_MENU)
   TITLE:=XFS filesystem support
   KCONFIG:=CONFIG_XFS_FS
+  DEPENDS:= +kmod-fs-exportfs
   FILES:=$(LINUX_DIR)/fs/xfs/xfs.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,xfs)
 endef
@@ -309,6 +355,43 @@ endef
 
 $(eval $(call KernelPackage,fs-xfs))
 
+define KernelPackage/fs-btrfs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=BTRFS filesystem support
+  KCONFIG:=\
+       CONFIG_CRYPTO_CRC32C \
+       CONFIG_LIBCRC32C \
+       CONFIG_BTRFS_FS \
+       CONFIG_BTRFS_FS_POSIX_ACL=n
+  # for crc32c
+  DEPENDS:=+kmod-crypto-core @!LINUX_2_6_21&&!LINUX_2_6_25&&!LINUX_2_6_28
+  FILES:=\
+       $(LINUX_DIR)/crypto/crc32c.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/lib/libcrc32c.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/fs/btrfs/btrfs.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,crc32c libcrc32c btrfs)
+endef
+
+define KernelPackage/fs-btrfs/description
+  Kernel module for BTRFS support
+endef
+
+$(eval $(call KernelPackage,fs-btrfs))
+
+define KernelPackage/fs-autofs4
+  SUBMENU:=$(FS_MENU)
+  TITLE:=AUTOFS4 filesystem support
+  KCONFIG:=CONFIG_AUTOFS4_FS 
+  FILES:=$(LINUX_DIR)/fs/autofs4/autofs4.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,autofs4)
+endef
+
+define KernelPackage/fs-autofs4/description
+  Kernel module for AutoFS4 support
+endef
+
+$(eval $(call KernelPackage,fs-autofs4))
+
 
 define KernelPackage/nls-base
   SUBMENU:=$(FS_MENU)
@@ -376,6 +459,23 @@ endef
 $(eval $(call KernelPackage,nls-cp852))
 
 
+define KernelPackage/nls-cp866
+  SUBMENU:=$(FS_MENU)
+  TITLE:=Codepage 866 (Cyrillic)
+  KCONFIG:=CONFIG_NLS_CODEPAGE_866
+  FILES:=$(LINUX_DIR)/fs/nls/nls_cp866.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,25,nls_cp866)
+$(call KernelPackage/nls/Depends)
+endef
+
+
+define KernelPackage/nls-cp866/description
+  Kernel module for NLS Codepage 866 (Cyrillic)
+endef
+
+$(eval $(call KernelPackage,nls-cp866))
+
+
 define KernelPackage/nls-cp1250
   SUBMENU:=$(FS_MENU)
   TITLE:=Codepage 1250 (Eastern Europe)
@@ -492,3 +592,37 @@ define KernelPackage/nls-utf8/description
 endef
 
 $(eval $(call KernelPackage,nls-utf8))
+
+
+define KernelPackage/nls-iso8859-13
+  SUBMENU:=$(FS_MENU)
+  TITLE:=ISO 8859-13 (Latin 7; Baltic)
+  KCONFIG:=CONFIG_NLS_ISO8859_13
+  FILES:=$(LINUX_DIR)/fs/nls/nls_iso8859-13.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,25,nls_iso8859-13)
+$(call KernelPackage/nls/Depends)
+endef
+
+
+define KernelPackage/nls-iso8859-13/description
+ Kernel module for NLS ISO 8859-13 (Latin 7; Baltic)
+endef
+
+$(eval $(call KernelPackage,nls-iso8859-13))
+
+define KernelPackage/nls-cp775
+  SUBMENU:=$(FS_MENU)
+  TITLE:=Codepage 775 (Baltic Rim)
+  KCONFIG:=CONFIG_NLS_CODEPAGE_775
+  FILES:=$(LINUX_DIR)/fs/nls/nls_cp775.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,25,nls_cp775)
+$(call KernelPackage/nls/Depends)
+endef
+
+
+define KernelPackage/nls-cp775/description
+ Kernel module for NLS Codepage 775 (Baltic Rim)
+endef
+
+$(eval $(call KernelPackage,nls-cp775))
+