pata-artop: no longer requires ide modules
[openwrt-10.03/.git] / package / kernel / modules / block.mk
index b9f4c0dbd4e6706807f88939cf88cb0d8377bbbb..aad932b3d5cd7b1752b97cab3f4726c2cb666be0 100644 (file)
@@ -19,3 +19,14 @@ define KernelPackage/ata-piix
        DEPENDS:=+kmod-libata +kmod-ide-core +kmod-scsi-core
 endef
 $(eval $(call KernelPackage,ata-piix))
+
+define KernelPackage/pata-artop
+       TITLE:=pata-artop
+       DESCRIPTION:=Kernel module for ARTOP PATA controller
+       KCONFIG:=$(CONFIG_PATA_ARTOP)
+       SUBMENU:=$(BLMENU)
+       AUTOLOAD:=$(call AutoLoad,30,libata pata_artop)
+       FILES:=$(LINUX_DIR)/drivers/ata/pata_artop.$(LINUX_KMOD_SUFFIX)
+       DEPENDS:=+kmod-libata +kmod-scsi-core
+endef
+$(eval $(call KernelPackage,pata-artop))