This series of patches closes the support gap on one of the explicitly
[openwrt-10.03/.git] / package / iw / Makefile
index 36361fb3177bdb9ed179410901a747de4e48663d..1118df867000abf04e7c1f857860d0bae6a1a7d2 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,8 +9,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iw
-PKG_REV:=11b24c28b802bae2abda8f46d457df60fa602594
-PKG_VERSION:=20071130_$(PKG_REV)
+PKG_REV:=4d3a72da3f21761bf4f2866a6a3400d4ecf67365
+PKG_VERSION:=20080414_$(PKG_REV)
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -38,9 +38,11 @@ MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/mac80211 -I$(STAGING_DIR)/usr/include/libnl -I$(STAGING_DIR)/usr/include" \
        LDFLAGS="-L$(STAGING_DIR)/usr/lib -lnl"
 
-define Package/iw/install
+ifneq ($(CONFIG_LINUX_2_6_23),)
+  define Package/iw/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/iw $(1)/usr/sbin/
-endef
+  endef
+endif
 
 $(eval $(call BuildPackage,iw))