remove warning from hotplug2, which pops up 10 times during boot
[openwrt-10.03/.git] / package / hotplug2 / Makefile
index 94aadc085334bd4785878703b2f681c08acb7bac..cccad9bef65a8a2f4660ace76701041197e95314 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hotplug2
 PKG_VERSION:=0.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
@@ -19,17 +19,19 @@ PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
 include $(INCLUDE_DIR)/package.mk
 
 define Package/hotplug2
-  SECTION:=utils
-  CATEGORY:=Utilities
+  SECTION:=base
+  CATEGORY:=Base system
+  VERSION:=0.9+r102-$(PKG_RELEASE)
   TITLE:=Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
 endef
 
 define Package/hotplug2/description
-Hotplug2 is a trivial replacement of some of the UDev functionality
-in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
+ Hotplug2 is a trivial replacement of some of the UDev functionality
+ in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
 endef
-MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES"
+
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES -I."
 
 define Package/hotplug2/install
        $(INSTALL_DIR) $(1)/etc