remove warning from hotplug2, which pops up 10 times during boot
[openwrt-10.03/.git] / package / hotplug2 / Makefile
index 3d1729cb550404f0bec3b59ed73aca2f43962717..cccad9bef65a8a2f4660ace76701041197e95314 100644 (file)
@@ -10,29 +10,32 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hotplug2
 PKG_VERSION:=0.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
 PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
-PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/hotplug2
-  SECTION:=utils
-  CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6 +udevtrigger
+  SECTION:=base
+  CATEGORY:=Base system
+  VERSION:=0.9+r102-$(PKG_RELEASE)
   TITLE:=Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
 endef
 
 define Package/hotplug2/description
-Hotplug2 is a trivial replacement of some of the UDev functionality
-in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
+ Hotplug2 is a trivial replacement of some of the UDev functionality
+ in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
 endef
 
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES -I."
+
 define Package/hotplug2/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
 endef