disable CONFIG_EMBEDDED for x86-2.6, enable KALLSYMS
[openwrt-10.03/.git] / package / hostapd / patches / 001-cross_compile_fix.patch
index ca2bb23c7753983e24922ef4ad9144a0eeef9101..669264cb64567b393a9699ef106856f51acaad3b 100644 (file)
@@ -1,8 +1,10 @@
-diff -ruN hostapd-0.3.9-old/Makefile hostapd-0.3.9-new/Makefile
---- hostapd-0.3.9-old/Makefile 2005-06-11 05:03:36.000000000 +0200
-+++ hostapd-0.3.9-new/Makefile 2005-08-14 08:09:52.000000000 +0200
-@@ -3,7 +3,7 @@
- DIR_HOSTAP=.
+Common subdirectories: hostapd-0.5.2/logwatch and hostapd-0.5.2.new/logwatch
+Index: hostapd-0.5.7/Makefile
+===================================================================
+--- hostapd-0.5.7.orig/Makefile        2007-06-04 13:22:31.790022464 +0200
++++ hostapd-0.5.7/Makefile     2007-06-04 13:22:31.856012432 +0200
+@@ -2,7 +2,7 @@
+ DIR_WPA_SUPPLICANT=.
  
  ifndef CFLAGS
 -CFLAGS = -MMD -O2 -Wall -g
@@ -10,7 +12,7 @@ diff -ruN hostapd-0.3.9-old/Makefile hostapd-0.3.9-new/Makefile
  endif
  
  # define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
-@@ -173,7 +173,7 @@
+@@ -336,7 +336,7 @@
        for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
  
  hostapd: $(OBJS)
@@ -19,3 +21,16 @@ diff -ruN hostapd-0.3.9-old/Makefile hostapd-0.3.9-new/Makefile
  
  driver_conf.c: Makefile .config
        rm -f driver_conf.c
+@@ -400,10 +400,10 @@
+ endif
+ nt_password_hash: $(NOBJS)
+-      $(CC) -o nt_password_hash $(NOBJS) $(LIBS_n)
++      $(CC) -o nt_password_hash $(NOBJS) $(LDFLAGS) $(LIBS_n)
+ hlr_auc_gw: $(HOBJS)
+-      $(CC) -o hlr_auc_gw $(HOBJS) $(LIBS_h)
++      $(CC) -o hlr_auc_gw $(HOBJS) $(LDFLAGS) $(LIBS_h)
+ clean:
+       rm -f core *~ *.o hostapd hostapd_cli nt_password_hash hlr_auc_gw