[ar71xx] defconfig: move defaults from /etc/config/defaults/ to /etc/defconfig/,...
[openwrt-10.03/.git] / package / gdb / Makefile
index a2d5c85348eb7bcd25ede760de3f2d867950bc0b..c2fc2e97b3926eed673e2ef600def2b109ae5d0d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=6.3
+PKG_VERSION:=6.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=05b928f41fa5b482e49ca2c24762a0ae
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/gdb
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=@GNU/gdb
+PKG_MD5SUM:=c9da266b884fb8fa54df786dfaadbc7a
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -40,14 +39,16 @@ define Package/gdbserver/description
  than the one which is running the program being debugged.
 endef
 
-TARGET_CPPFLAGS += -I$(STAGING_DIR)/usr/include
-TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib
+CONFIGURE_ARGS+= \
+       --with-system-readline
 
-export ac_cv_search_tgetent=$(TARGET_LDFLAGS) -lncurses -lreadline
+CONFIGURE_VARS+= \
+       ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
                all install-gdb
 endef
 
@@ -58,7 +59,7 @@ endef
 
 define Package/gdbserver/install       
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdb $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,gdb))