This series of patches closes the support gap on one of the explicitly
[openwrt-10.03/.git] / package / fuse / patches / 112-no_break_on_mknod.patch
index 96ed70f2917e03d976474aa0f87735a2db783198..911d25c12f7494b640881d2133cf8c89ae256654 100644 (file)
@@ -1,12 +1,11 @@
-diff -ruN fuse-2.4.1-old/util/Makefile.in fuse-2.4.1-new/util/Makefile.in
---- fuse-2.4.1-old/util/Makefile.in    2005-10-17 12:29:20.000000000 +0200
-+++ fuse-2.4.1-new/util/Makefile.in    2005-10-19 17:11:13.000000000 +0200
-@@ -445,7 +445,7 @@
+--- fuse-2.7.3.orig/util/Makefile.in   2008-02-19 15:00:55.000000000 -0500
++++ fuse-2.7.3/util/Makefile.in        2008-03-17 14:14:10.000000000 -0400
+@@ -528,7 +528,7 @@
  install-exec-hook:
        -chown root $(DESTDIR)$(bindir)/fusermount
        -chmod u+s $(DESTDIR)$(bindir)/fusermount
 -      @if test ! -e $(DESTDIR)/dev/fuse; then \
 +      -@if test ! -e $(DESTDIR)/dev/fuse; then \
                $(mkdir_p) $(DESTDIR)/dev; \
-               echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229"; \
-               mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229; \
+               echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229 || true"; \
+               mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229 || true; \