ath79: add support for jjPlus JA76PF2
[openwrt/.git] / package / firmware / layerscape / ppfe-firmware / Makefile
index 431cf262358c7b97a690daa7ca43c8c1380186ca..3909b06302c9567687fe825d72c7e699fe28fc7b 100644 (file)
@@ -8,15 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ppfe
-PKG_VERSION:=2017.09
+PKG_VERSION:=lsdk-1806
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/qoriq-open-source/engine-pfe-bin.git
-PKG_SOURCE_VERSION:=97cd13d3070d7199e62881bc495b332194b67edd
-PKG_MIRROR_HASH:=1ef60cdac49dd57c76ec9ef01d00f6eeb025ba62f0d75f54adeeb3362f5edad2
-
-PKG_FLAGS:=nonshared
+PKG_SOURCE_URL:=https://github.com/NXP/qoriq-engine-pfe-bin.git
+PKG_SOURCE_VERSION:=50c825b9300c5e36548fb5dcbef538b650fc1913
+PKG_MIRROR_HASH:=7627ce260ac4b320f3a7e8ad81db1c3ec2266332762dd1e4313480f7a678fd43
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,12 +24,12 @@ STRIP:=:
 define Package/layerscape-ppfe
   SECTION:=firmware
   CATEGORY:=Firmware
-  DEPENDS:=@TARGET_layerscape
   TITLE:=NXP Layerscape PPFE firmware
+  DEPENDS:=@TARGET_layerscape
   CONFIG_FW:=ls1012a/u-boot/pfe_fw_sbl.itb
   CONFIG_BIN1:=ls1012a/slow_path/ppfe_class_ls1012a.elf
   CONFIG_BIN2:=ls1012a/slow_path/ppfe_tmu_ls1012a.elf
-  CONFIG_LIC:=Freescale-Binary-EULA
+  CONFIG_LIC:=NXP-Binary-EULA.txt
 endef
 
 define Build/Compile