firewall: emit hotplug events for interface add/remove
[openwrt-10.03/.git] / package / firewall / Makefile
index 9d4e5dd31a727e6de1573058b04ebb424006e109..0f1b1118d7a1a4bd8556dec1f65c544df936f7b3 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_RELEASE:=5
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -19,6 +19,7 @@ define Package/firewall
   URL:=http://openwrt.org/
   TITLE:=OpenWrt firewall
   DEPENDS:=+iptables-mod-conntrack +iptables-mod-nat
+  PKGARCH:=all
 endef
 
 define Package/firewall/description
@@ -42,6 +43,8 @@ define Package/firewall/install
        $(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/20-firewall $(1)/etc/hotplug.d/iface
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/firewall.user $(1)/etc
 endef
 
 $(eval $(call BuildPackage,firewall))